I am using latest version of Telescope 0.20.5 and have got all the packages that comes with it from github. I'm trying to add a new theme as package to my Telescope. I added "telescope-theme-crater" package in the directory and ran meteor command. It gave me following error:

=> Errors while adding packages:

While selecting package versions: error: unknown package: telescope-lib Required by: telescope-theme-crater 0.0.0

unknown package: telescope-core

Required by: telescope-theme-crater 0.0.0

This is strange as both of the required packages are already there in the packages directory.

I tried adding a custom package which again gave an error as:

=> Errors while parsing arguments:

While adding package custom:

error: no such package

This is again strange as I have this package present in packages directory.

Kindly help me figure out and resolve this problem. It's cruicial as my app is stuck at this point. Can't move further.

Comments

JeremyJeremy
2 years ago

Crater is using an older version of Telescope and the theme is likely very incompatible with the latest version. You'll have to dig through the theme package and update any references to the old methods of doing things. You can check the docs for a reference of how things are currently done http://telescope.readme.io/v0.20/docs

To clarify on your error, you're getting that because it's telescope:core and telescope:lib now (not telescope-core and telescope-lib). That change happened when all of the packages were published to Atmosphere.

Reply